Error when applying new certificate to EDR console
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Error when applying new certificate to EDR console

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Article ID: 278699

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Updated On:

Products

Advanced Threat Protection Platform Endpoint Detection and Response

Issue/Introduction

When putting in a certificate you receive an error that the SAN was unable to be resolved.

Environment

EDR 4.7.x to Current.

Cause

As of SEDR 4.7.x a check was introduced to verify the fields in the certificate. This is to ensure that the entires in the SAN have a resolvable reverse lookup.

 

Resolution

First verify that the EDR can perform a reverse lookup of the all A records and/or CNAMEs listed in the certificate (whether listed as the common name or in the SAN field) by running nslookup on the EDR CLI.

If the EDR is unable to resolve one or more of the entries via nslookup, follow up with your internal DNS team to ensure that reverse lookup entries are added to DNS.