Running an Explore/Correlate against custom endpoint (DYN) the accounts is being correlated to the "default user"
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Running an Explore/Correlate against custom endpoint (DYN) the accounts is being correlated to the "default user"

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Article ID: 278674

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Create a new customer endpoint, using Connector XPress, the Explore is working fine but the Correlate always correlates with [default user]

This connector has a requirement that it needs a different attribute to be correlated, not the user ID since it has a different value of the Global User.

This endpoint has an API Gateway in the middle to retrieve the data from the endpoint.

Environment

Identity Manager 14.4.x

Cause

The root cause is the API Gateway that only retrieves the user ID attribute, we can confirm that from JXplorer or any other LDAP browser

  • Using JXplorer and connecting to Provisioning Server port 20389, in the custom endpoint, the accounts have the eTDYN-str-multi-XX attribute with the correct value.
  • Using JXplorer and connecting to Provisioning Directory port 20391, in the custom endpoint, the accounts have no eTDYN-str-multi-XX attribute
  • Running a new Explore in the custom endpoint and checking the Provisioning Directory and the attribute is not in the endpoint accounts.

 

Note: The eTDYN-str-multi-XX attribute was defined in the Connector XPress, see the correct attribute in the Connector XPress project.

Resolution

This is not an Identity Manager problem, but an API Gateway configuration that the customer needs to check to retrieve both the ID and the attribute used to correlate with the Global Users.