Error loading a Job/Task by a user in a non-admin security role
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Error loading a Job/Task by a user in a non-admin security role

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Article ID: 278665

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Updated On:

Products

Client Management Suite

Issue/Introduction

This specific job/task produces an error when an end user tries to access it. 

In the Notification Server logs, we see that this user does not have access to load the item: 644a995e-211a-4d94-aa8a-788413b7be5d

This item, when clicked in the Altiris Log Viewer shows it is “Software Component Supersedes Software Component”.

Cause

The user does not have the needed permissions to read an association item, Software Component Supersedes Software Component, in the role(s) they are in.

Resolution

  1. While logged in as a user in the Symantec Administrator role, Open the Security Role Manager (Settings > Security > Security Role Manager).
  2. Change the role if needed at the top drop-down to the role that is missing the permission
  3. In the View drop-down choose All Items
  4. Below this dropdown on the left tree, go to and highlight Settings > Notification Server > Resource and Data Class Settings > Resource Associations > Software Management > Software Component Supersedes Software Component
  5. On the right pane, select the Read option for System Permissions and the Read Resource Association options for Resource Management Permissions