Autosys errors when migrating views between environments
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Autosys errors when migrating views between environments

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Article ID: 278645

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

We are upgrading our Autosys to 12.0 and we need help on export our views and import them in our next Autosys environment.  
Last time we had issue loading view that had boxes associated with them.  

Environment

Autosys R12.x
WCC R12.x

Cause

The two environments are not identical.
There are differences in instance names, machines, and job definitions.

Resolution

It is expected when you export Views from one environment to another that the environments are identical.
If they are not then it is expect that the imports may run into issues and you will need to correct your imports for the missing or dependencies.
We do not have any way to validate this or utilities to correct this as this information is completely unique to you.
Support can not look at the files and help identify problems head of time is such as use case.

If the problems is with missing machines, and jobs then you could export the machines and jobs from both environments to a file and use file compare tool to find the differences.
Then once you create your export files search for the things that are missing in the new environment and remove them from the import file.

Below is the documentation on export and importing views
https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/autosys-workload-automation/12-1/monitoring-and-reporting/ca-wcc-monitoring-and-reporting/ca-wcc-monitoring-application/export-and-import-views-in-the-monitoring-application.html

Additional Information

CA Workload Control Center Job Flow Monitoring Views Migration Failure. Error : E140031 Unknown server specified <ServerName>