VIP Auth Hub adminconsole HTTP error 504
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VIP Auth Hub adminconsole HTTP error 504

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Article ID: 278583

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Updated On:

Products

VIP Authentication Hub

Issue/Introduction

After a new deployment of  VIP Auth Hub version 2.2.2+1012, user can not access admin console, encounters gateway timeout error 504, after 15 seconds of idly waiting.

Environment

VIP Auth Hub version 2.2.2+1012
Azure AKS Kubernetes 1.27.3
Ubuntu 22.04.3 LTS

Cause

Please verify the following first:

1. All pods are up running and no errors. (Kubectl get pods -n <namespace>)

2. The browser must be allowed to run java script. Some company may have browser rules or settings in place to prevent that.

3. Access each load balancer pod and admin console pod and view its logs.  (kubectl logs <full container pod name>  -n <namespace>)

It was identified that some of admin console pods are not accessible from Kubernetes command line, and no logs are displayed either.

Strict firewall rule may have prevented inter-communication among the pods. These inter-communication among the pods are important by design in order for VIP auth hub cluster to work.

Logging (10250) and admin console (8025) access are on different ports within the cluster.

The url request to admin console was able to reach ingress load balancer, but did not reach further to any of admin console pod, hence the gateway timeout error 504.

Resolution

When Azure AKS cluster infrastructure was created, there was strict firewall rule to prevent inter-communication among the pods, which was NOT expected.

AKS cluster infrastructure team can correct the firewall rule by editing the rule and allowing inter-communication among the pods. 

This allows admin console access, also resolves pod logging problems too.