Processes Are Not Starting after installing Windows System and Windows Defender Updates
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Processes Are Not Starting after installing Windows System and Windows Defender Updates

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Article ID: 278545

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After installing Microsoft Updates and Updates to Windows Defender, ITPAM workflows are failing to start 

Environment

ITPAM 4.3.05

ITPAM 4.4

Multiple Agents configured with TLS 1.2

Cause

Processes stopped running because the database was overwhelmed by messages from agents that were not connecting due to "Use Deprecated Communication" being configured

Resolution

Disabled "Use Deprecated Communication" option on all Agents

Ensured the following step was followed from Post Install Steps

"Change Agent Configuration from Simplified to Deprecated Communication"

If an agent is configured to use simplified communication, you can configure the agent to use deprecated communication.

Follow these steps:

  1. Click the Configuration tab and expand Agents on the Configuration Browser palette.
  2. Select the agent for which to switch communication and click Lock.
  3. Select the Properties tab for the selected agent.
  4. Check the Use Deprecated Communication check box.
  5. Select the agent and click Unlock.
  6. Click Yes on the Unsaved Data dialog to save the changes.

The data of the agent is saved and the agent is configured to deprecated communication mode.

Reference

Post Installation Tasks for Agents