Endpoint Protection Linux Agent install error; "not fully Installed"
search cancel

Endpoint Protection Linux Agent install error; "not fully Installed"

book

Article ID: 278539

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

During the Symantec Endpoint Protection, "SEP", Linux agent installation it does not complete. It fails with the following error; "Agent is not fully installed, not all packages are installed". 

It also gives this same error post installation, if you run the status script.; /usr/lib/symantec/status.sh

Attempts to reinstall the SEP agent fails, it does not ever complete properly.

Initial Agent version was SEP 14.3 RU5.  Tried upgrading to SEP 14.3 RU6 and SEP 14.3 RU8, but both of these versions failed with the exact same errors.

 

 

Environment

Red Hat Linux 

Symantec Endpoint Protection 14.3 RU5, 14.3 RU6, 14.3 RU8

 

Cause

The Linux systems RPM database was corrupted, and was giving the installation program incorrect information during the install.  

During the installation the install program checks the RPM database to validate that the files were installed properly.  When it did a query to see if the RPMs were installed, RPM responds back that they were not, and the installation program errors out.

 

Resolution

Repaired RPM Database.

#rpm --rebuilddb

Once this was finished we ran the installation again and it completed properly.

Additional Information

Gathered a getagent info log to validate that the RPMs were installed.  

Enabled debug logging on the installation to see the invalid responses from the RPM database.; ./LinuxInstaller -- --debug

Run the install with debug logging and collected the; /var/log/sdcsslog/sdcss_install.log

It gave the details where the install was unable to validate the RPM database, and is not answering properly.