Multiple SessionAuthenticationService Error logs in the app-ca logs
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Multiple SessionAuthenticationService Error logs in the app-ca logs

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Article ID: 278532

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

In the app ca logs below logs are seen 

ERROR 2024-01-12 16:44:34,910 [http-nio-82-exec-1] security.SessionAuthenticationService (clarity:unknown:XXXXXX__0DAA9CA7-2997-4639-A9F1-2592ECB01A47:PPM_REST_API) (a96500bb-519b-4ea5-9287-deb8a79fb0cb) SessionAuthenticationService:: SecurityIdentifier is not valid: unknown::en::20239043__0DAA9CA7-2997-4639-A9F1-2592ECB01A47 sessionId = XXXXXX__0DAA9CA7-2997-4639-A9F1-2592ECB01A47
ERROR 2024-01-12 16:44:34,910 [http-nio-82-exec-1] security.SessionAuthenticationService (clarity:unknown:XXXXXX__0DAA9CA7-2997-4639-A9F1-2592ECB01A47:PPM_REST_API) (a96500bb-519b-4ea5-9287-deb8a79fb0cb) SessionAuthenticationService:: sessionId = XXXXXX__0DAA9CA7-2997-4639-A9F1-2592ECB01A47
ERROR 2024-01-12 16:44:34,910 [http-nio-82-exec-1] security.SessionAuthenticationService (clarity:unknown:XXXXXX__0DAA9CA7-2997-4639-A9F1-2592ECB01A47:PPM_REST_API) (a96500bb-519b-4ea5-9287-deb8a79fb0cb) SessionAuthenticationService:: isLoggedIn = false

Environment

All Clarity Supported Version with SSO integration 

Cause

These errors are not cause of concern, however app logs gets flooded 

Resolution

This happens when a user clicks on an expired session in Clarity UI.