CAU Windows Agent fails with "Update of INI from 'iniPatch.txt' failed"
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CAU Windows Agent fails with "Update of INI from 'iniPatch.txt' failed"

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Article ID: 278359

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

The Windows agent won't start after running a Centralized Agent Upgrade from 12.3 to 21.0.  There is only one line in the log file after the CAU:

Update of INI from 'iniPatch.txt' failed, reason: 6 - The handle is invalid. >libcpprnt/src/FileStream.cpp#sys::FileDescriptor::sync:208<

This is starting the agent from the .exe file

In the windows Event Viewer, under Windows Logs -> Applications, we saw the following error:

The description for Event ID 1000 from source UC4 Agent cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

Cause

Caused by the user needing elevated privileges (Start as Administrator) to start the agent

Resolution

This was resolved by right-clicking the ucxjwx6.exe file and choosing "Run as Administrator".  One indicator that this might be necessary is that when attempting to add lines to the agent's ini file, the ini file can't be saved without opening Notepad with "Run as Administrator"

We suggest the use of the service manager instead of using the executable to start the Windows agent.  This way the administrative permissions/authorizations are inherited through a windows service instead of needed to start the executable.

Beyond that, a system administrator may be able to see what is missing if they were to use the windows utility process monitor and see what system messages there are when attempting to start the executable.