LDAP Search fails from PolicyXpress
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LDAP Search fails from PolicyXpress

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Article ID: 278152

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Updated On:

Products

CA Identity Manager

Issue/Introduction

While doing a specific LDAP search from the Policy Xpress data element test we are seeing this error: The test has failed to run with the following error: "Failed executing LDAP search ."

Cause

There are multiple possible causes including unable to get a connection to the LDAP server, invalid or incorrectly specified LDAP search. etc.

Resolution

As there can be a variety of causes you should perform the following general troubleshooting to help focus on the root cause.

> Enable ims and im DEBUG logging to try and capture more details about the error in the server log.

> Validate that the target LDAP server is up and running. We have experienced that even a server that is running may require a restart, particularly if the query fails intermittently.

> Validate via JXplorer or a similar LDAP browser to the LDAP server that query works as expected.

> Run the query from the command line of the Identity Manager server using the ldapsearch. Ldapsearch is provided out-of-the-box in /Provisioning/bin or can be installed as a linux oackage, for example.