Error: 'Error generating final processed report - Database logon failed' in CCS
search cancel

Error: 'Error generating final processed report - Database logon failed' in CCS

book

Article ID: 278110

calendar_today

Updated On:

Products

Control Compliance Suite Control Compliance Suite Directory Services Control Compliance Suite Standards Database Control Compliance Suite Standards Module Control Compliance Suite Standards Server

Issue/Introduction

When running a report generation job in Control Compliance Suite (CCS), the job itself completes but no report is created. 

Looking at the job "Messages" it shows the error message:

"Error generating final processed report." and the details are "Database logon failed."

Cause

This will happen if the MS SQL SNAC 11 driver is uninstalled.

Resolution

You can either download the latest Microsoft SQL SNAC Driver (Server Native Client).

Or you can find it in the CCS Installset Redist folder "sqlncli_x64.msi".

Once that driver has been reinstalled on each CCS Manager with the Reporting Service role.
Restart the services, or reboot the servers.

Now run the report generation job once more, it will now complete successfully.