NTLM Authentication does not work in PAM Orchestrator
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NTLM Authentication does not work in PAM Orchestrator

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Article ID: 278033

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After configuring ntlm.enabled=true in OasisConfig.propeties, PAM does not allow authentication.

c2o.log shows the following

org.infinispan.container.entries.NullCacheEntry cannot be cast to org.infinispan.container.entries.MVCCEntry
UT005023: Exception handling request to /itpam: org.infinispan.remoting.RemoteException: ISPN000217: Received exception from 6e79497c-f72c-44ce-8c7a-55e3f1b00926, see cause for remote stack trace
    at org.infinispan.remoting.transport.ResponseCollectors.wrapRemoteException(ResponseCollectors.java:25)

Environment

ITPAM 4.4

Cause

Invalid steps to configure NTLM authentication

Resolution

Run the re-configure option (from the installer) to enable NTLM and during the reconfigure EEM Screen, provision to validate whether the user has access or not for the PAM application.