No SPS Agent traces created even if TraceFile is set to yes
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No SPS Agent traces created even if TraceFile is set to yes

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Article ID: 278017

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Updated On:

Products

CA Single Sign On Agents (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) SITEMINDER

Issue/Introduction


Running a CA Access Gateway (SPS), this one doesn't have the Agent traces generated even though the ACO parameter "TraceFile" set to "yes".

Is there another way to activate those traces?

 

Cause


There's a tab character after the ACO parameter name, probably due to the fact that the name comes from a copy and paste. This can be seen in the SPS Agent log:

spsagent.log:

[402830/139952136959744][Fri Jan 12 2024 15:20:12] traceconfigfile    =/<home_sps>/secure-proxy/proxy-engine/conf/defaultagent/FederationTrace.conf
[402830/139952136959744][Fri Jan 12 2024 15:20:12] tracefile=yes
[402830/139952136959744][Fri Jan 12 2024 15:20:12] tracefilename=/<home_sps>/secure-proxy/proxy-engine/log/spsagent-traces.log

 

Resolution

 

  • Ensure and modify if needed the SPS ACO parameter name:

    traceconfigfile    =

    to remove all characters after the last e letter

  • Restart the CA Access Gateway (SPS), the SPS Agent trace file will be created:

    /<home_sps>/secure-proxy/proxy-engine/log/spsagent-traces.log