Symantec Identity Governance - Exception while creating WS client: serviceClass:com.eurekify.services.BuildingBlockService
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Symantec Identity Governance - Exception while creating WS client: serviceClass:com.eurekify.services.BuildingBlockService

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Article ID: 278004

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Updated On:

Products

CA Identity Suite CA Identity Manager CA Identity Governance

Issue/Introduction

When trying to perform an import the below error is being thrown in the logs and the import is failing.

ERROR state. Reason: Exception caught during script evaluation. Script 'rcmInvoker', ScriptID=30:WPDS, JobID=27:WPDS, JobRef='Import[Import for universe] - TaskId:17', ProcessRef='BBAggImport', JobRowVersion=2, NodeName='Create Temp Configuration', ProcessNodeUUID=36b00f65-XXXX-XXXX-XXXX-60ebb, JobNodeID=91:WPDS, WorkItem=87:WPDS:1, FIFO=28. Exception was: com.workpoint.common.exception.ScriptEngineException: java.lang.RuntimeException: Exception while creating WS client: serviceClass:com.eurekify.services.BuildingBlockService url:http://hostname:8445/eurekify/services/buildingBlockService?wsdl Error occurred in Statement #1 in Script ID 30:WPDS, Script Name = 'rcmInvoker', Script type = 'Action'. Job ID = 27:WPDS, Process Ref = 'BBAggImport', Node Name = 'Create Temp Configuration', WorkItem = 87:WPDS:1

Cause

This issue is caused by either an issue with being able to connect to the wsdl URL or incorrect wsdl URL configuration.

Resolution

If you are utilizing VAPP the default Non-ssl port is 8082 while SSL utilized 8445. If you are using standalone then you will be responsible for knowing which ports you configured during the installation. Confirm you can connect to the below URL's:

Secure Connections:
https://10.100.10.10:8445/eurekify/services/buildingBlockService?wsdl
https://LoadBalancerIP/eurekify/services/buildingBlockService?wsdl

Non-Secure Connection:
http//10.100.10.10:8082/eurekify/services/buildingBlockService?wsdl

If the connection attempts fail, you will want to work with your networking team to ensure that the correct ports are open and available.

If all the above connections are successful, the next step is to compare the URL in the error vs the working URL's.

In the above error, you can see that the (Http) value is incorrect and should be HTTPS or that the port should be changed to the non-secure port.

http://hostname:8445/eurekify/services/buildingBlockService?wsdl 

To fix this navigate to:

Home > Administration > Settings > Common Property Settings

Search for buildingBlockService

You will see the buildingBlockService.url.

Update:

url:http://hostname:8445/eurekify/services/buildingBlockService

to:

url:https://hostname:8445/eurekify/services/buildingBlockService

or 

url:https://hostname:8082/eurekify/services/buildingBlockService

Port 8445 is the secure port. If you wish to use nonsecure port then change the port from 8445 to 8082.

Once the new values are set within the Common Property Settings, cycle IG to confirm that the settings stick and test again.

Additional Information

Additionally, there is a known issue with imports if you have any stale or offline endpoints, this will cause the import to fail.

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-governance/14-5/release-notes/known-issues.html

Titled Section:

Ignore Non-Imported Failed Endpoints