MSSQL target account synchronization issue due to SSL encryption error
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MSSQL target account synchronization issue due to SSL encryption error

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Article ID: 277913

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When a PAM administrator tries to verify or update an MSSQL target account, an SSL error "driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption" in encountered. The SSL error is reported in PAM's Tomcat logs. The administrator ran into this issue as the database server configuration allowed ONLY SSL/TLS connections, that is, the database server previously did not enforce SSL/TLS connections.

Cause

Configuration issue - Using the MS SQL connector, but Target Application configuration (via Credentials==>Manage Targets===>Applications)  in PAM has not enabled "SSL/TLS" connections for MSSQL.

Resolution

 

Via PAM UI, ensure that the Target Application's "MSSQL" tab has "SSL/TLS" enabled, if your MSSQL server is configured to only allow secure connections.