Catalog/PAM Autointegration and Manual integration both failing
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Catalog/PAM Autointegration and Manual integration both failing

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Article ID: 277899

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Updated On:

Products

CA Service Catalog CA Process Automation Base Process Automation Manager

Issue/Introduction

While attempting to integrate PAM with Service Catalog, the integration fails.  

Integration is being attempted on the install process to be performed automatically.  Existing documentation to manually integrate also does not work.  

Being told from Catalog during test attempt

CA Process Automation cannot connect to CA Service Catalog.  In CA Process Automation, review the CheckSLCMConnectivity process for possible reasons why the connection failed.  Examples include the following:

- Processes not loaded from CA Service Catalog
- The password for CA Service Catalog is expired
- Certificate based authenticatio is not configured properly.

Environment

CA Service Catalog 17.3 and Higher

CA Process Automation 4.x

Cause

PAM environment had were existing settings that needed to be reviewed.

Resolution

In one such instance, the Process Automation parameters at the "SLCM_GlobalDataset" level had a different user as well as in the catalog url pointed to only the server 

Settings of interest are the "userID__" and "password" parameters as well as the "SLCM_URL" setting.  These are all settings one must access from PAM Orchestrator under the SLCM_GlobalDataset in order to address.