SOI - Sending notification email does not work
search cancel

SOI - Sending notification email does not work

book

Article ID: 277802

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

After configuring SMTP settings in the SOI, the recipient does not receive any notification email - the feature does not seem to work at all.

Environment

SOI 4.2 CU1-CU5

Cause

The customer's application required TLS 1.2 and stronger ciphers to establish a secure TLS connection - in SOI, only TLS 1.0 / 1.1 is implemented.

Resolution

1. Stop all the SOI services
2. Take a backup of the below jar (mail-1.4 or mail-1.4.1) and replace it with the attached jar (mail-1.6.2)

          CA\SOI\EventManagement\lib\mail-1.4.1.jar

          CA\SOI\indexer\lib\mail-1.4.1.jar

          CA\SOI\tomcat\lib\mail-1.4.1.jar

          CA\SOI\SamUI\lib\mail-1.4.1.jar

          CA\SOI\ucfbroker\lib\mail-1.4.1.jar

 

 

    3. Also, Please take a backup of below jar and replace it from attached.  

        CA\SOI\tomcat\lib\ oi.common.sam-4.2.0-manager.jar

        CA\SOI\SamUI\lib\soi.common.sam-4.2.0-ui.jar

 

    4. Start all the SOI services with recommended steps.

Attachments

Mail-TLS-1.2-support-jar.zip get_app