Spectrum WebApp fails to load
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Spectrum WebApp fails to load

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Article ID: 277640

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When launching the Spectrum WebApp from the OneClick administration website it fails to load.

The loading icon appears but never loads the login request to access the WebApp.

Environment

All supported DX NetOps Spectrum releases

Cause

The /etc/hosts file has incorrect IP addresses assigned. It has transposed IP addresses for the two OneClick host entries in the file. OneClick Host A was set with the IP for OneClick Host B. OneClick Host B was set with the IP for OneClick Host A.

Resolution

To resolve this:

  1. Correct the /etc/hosts file.
  2. Stop the webtomcat service. Use the command:
    • $SPECROOT/webtomcat/bin/stopWebTomcat.sh
  3. Stop the tomcat service. Use the command:
    • $SPECROOT/tomcat/bin/stopTomcat.sh
  4. Start the tomcat service. Use the command:
    • $SPECROOT/tomcat/bin/startTomcat.sh
  5. Start the webtomcat service. Use the command:
    • $SPECROOT/webtomcat/bin/startWebTomcat.sh

The WebApp should now successfully launch.