Set SD Job timeout error SDG001097
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Set SD Job timeout error SDG001097

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Article ID: 277581

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery

Issue/Introduction

During creation of a SD Job when setting a Job timeout (example : 1 hour), following error appears :

One or more jobs/deliveries has specified a job timeout that is less than the minimum allowed (0 days, 3 hours). [SDG001097]

Environment

Client Automation 14.5

Cause

By default the allowed values for SD Job timeout are :
 
Minimum value = 3 hours
Maximum value = 7 days

Resolution

It is possible to change the minimum or maximum timeout values in DSM Explorer :

1- Open DSM Explorer and go under
Control Panel/Configuration/Software Job Management/Job Handling
 
2- Set the new minimum or maximum timeout value :

Example : Minimum set to 1 hour

3- Click Apply button

Additional Information

These values are stored in Domain Manager comstore under :
itrm/usd/manager/MinActivationTime
itrm/usd/manager/MaxActivationTime
 
and values (exprimed in number of hours) can be seen with :
 
ccnfcmda -cmd GetParameterValue -ps itrm/usd/manager -pn MinActivationTime
ccnfcmda -cmd GetParameterValue -ps itrm/usd/manager -pn MaxActivationTime