Unable to login to Clarity after Postgres server PORT changed
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Unable to login to Clarity after Postgres server PORT changed

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Article ID: 277505

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

We had upgraded our Postgres DB from v14 to v15.5 and during the process we moved from default port 5432 to 5442 and we made necessary change with respect to PORT in NSA, but fails to login to Clarity.

Environment

Clarity: 16.1.3

Cause

On review of logs we can see below error and it shows that the issue is with DB link as it is permanent DB link, henceforth still reference to old port captured when initially created prior to changing the DB server port in NSA.

com.niku.union.persistence.DBConnectionException: org.postgresql.util.PSQLException: Error could not establish connection

Detail: connection to server at "HOSTNAME", port 5432 failed: Connection refused

....

Where: SQL statement "SELECT dblink_connect('myconn', 'loopback_dblink')"

Resolution

To resolve the issue either of the below operations can be performed by DBA

Solution 1

1: Stop the Clarity services

2: Delete the Existing DB link

3: Save the new properties and PORT in the NSA

4: Run the command admin db create-db-link as per KB https://knowledge.broadcom.com/external/article?articleNumber=202837

         5: Start the Clarity services

Solution 2

1: Stop the Clarity services

2: Let your DBA update the PORT for existing db-link to new PORT

3: Start the Clarity services