Getting the red banner of death when attempting to install a new license file in DLP
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Getting the red banner of death when attempting to install a new license file in DLP

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Article ID: 277501

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

You see the generic red banner of death when attempting to install a new license file in the DLP Enforce Server.

The localhost log contains this entry when attempting to install the license file

Level: SEVERE
Source: com.vontu.manager.spring.web.ManagerHandlerExceptionResolver
Message: Unexpected exception while processing request:
Cause:
javax.validation.ValidationException: HV000028: Unexpected exception during isValid call.javax.validation.ValidationException: HV000028: Unexpected exception during isValid call.

Caused by: org.springframework.dao.IncorrectResultSizeDataAccessException: query did not return a unique result: 2; nested exception is javax.persistence.NonUniqueResultException: query did not return a unique result: 2

Resolution

  1. Remove the current licenses from the “ProgramData > Symantec > DataLossPrevention > EnforceServer > <version> > license” directory. (Keep the old license as a backup in case the new file does not work.)
  2. Copy the new license file into the license directory.
  3. Restart the Enforce Server services.
  4. Confirm that the new license file has been applied.