Service Catalog asking for Credentials in NTLM Environment
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Service Catalog asking for Credentials in NTLM Environment

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Article ID: 277446

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Updated On:

Products

CA Service Catalog

Issue/Introduction

In a Service Management Environment with NTLM authentication configured, a popup is generated asking for authorization when trying to access Service Catalog

The pop up reads:

Sign in to access this site

Authorization required by http://<server_name>:<server_port>

Your connection to this site is not secure

Authentication to Service Desk Manager and Web Screen Painter work as expected

View logs in Service Catalog show these errors

2023/12/18 15.04.30.723 ERROR [http-nio-8081-exec-1] [SSOConfiguration] federationIssuer configuration parameter not set
2023/12/18 15.04.30.723 ERROR [http-nio-8081-exec-1] [SSOConfiguration] federationRealm configuration parameter not set
2023/12/18 15.04.30.724 ERROR [http-nio-8081-exec-1] [SSOConfiguration] federationThumbprint configuration parameter not set
2023/12/18 15.04.30.724 ERROR [http-nio-8081-exec-1] [SSOConfiguration] federationFriendlyName configuration parameter not set
2023/12/18 15.04.30.724 ERROR [http-nio-8081-exec-1] [SSOConfiguration] federationAudienceuris configuration parameter not set
2023/12/18 15.04.30.724 ERROR [http-nio-8081-exec-1] [SSOConfiguration] federationReply configuration parameter not set

Environment

Service Management 17.3+

NTLM

Cause

These parameters mentioned in error logs are not necessary and can be deleted as customer does not have SAML SSO configured

Resolution

After deleting the parameters in the logs from C:\Program Files\CA\Service Catalog\view\webapps\usm\WEB-INF\web.xml

federationIssuer 
federationRealm 
federationThumbprint 
federationFriendlyName 
federationAudienceuris
federationReply 

The authentication worked as expected