e2e_appmon alarm Unable to start on time - delayed 261144 seconds
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e2e_appmon alarm Unable to start on time - delayed 261144 seconds

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Article ID: 277392

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

e2e_appmon alarm Unable to start on time - delayed 'n' seconds

This alarm of Warning severity was being generated for e2e profiles whether or not the e2e_appmon profile was running or disabled. The alarm was misleading and the customer wanted to stop the alarm.

Environment

  • e2e_appmon v3.01
  • NimRecorder 7.2.65

Cause

  • e2e_appmon default alarm configuration

Resolution

The associated actual, persistent alarm "Unable to start on time - delayed 261144 seconds"

was being generated due to:

a) the e2e probe saving the Last run time and

b) comparing the Last run time to when the script started again / even if the e2e profile had been disabled.

To prevent the alarm we set the following parameter from yes to no to disable the alarm.

   alarm_on_interval_breach = no

From the techdocs: "In the Alarm on Interval Breach section, select Publish Alarm to generate an alarm when the script execution duration is longer than the threshold value."

To help distribute the change to other e2e workstations (100 machines) we created a configuration package named:

e2e_appmon_disable_alarm_on_interval_breach

Then we set the following inside the package:

<setup>overwrite

   alarm_on_interval_breach = no

<\setup>

Then we tested it by acknowledging the existing alarm messages and restarting the e2e_appmon probe which confirmed that the alarm message no longer occurred.

Tested and confirmed on two e2e workstations.