While working on messagegtw to ServiceNow integration/setup, we want to confirm the exact number of alarms generated (without suppression) which creates events in Service Now.
Environment
DX UIM 20.4 CU9
Cause
messagegtw integration with ServiceNow events
Need for validating the alarm count/integration between the messagegtw sending alarms and the associated ServiceNow events.
Resolution
Set the nas Transaction Log Management "Log alarm updates every 'n' duplicate messages to 1 to avoid aggregation of suppressed alarms/alarm count.
Download and use SQLite browser and query the local nas transactionlog.db (alarm history) on the Primary hub to query and list every single alarm without suppression.
Open the nas_transaction_log table in 'Read-only' mode.
Note that once the initial review has been performed/report generated, it is advisable to set the "Log alarm updates every n messages" back to the default of 100.