DBCA fails with DIM-00019 when installing a fresh Oracle 19c Standard Edition 2 Database
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DBCA fails with DIM-00019 when installing a fresh Oracle 19c Standard Edition 2 Database

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Article ID: 277323

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Oracle Standard Edition 2

Issue/Introduction

When running the DBCA tool to install a fresh instance of Oracle 19c Standard Edition 2 Database you encounter DIM-00019 error. It will may be accompanied with two more ORA-12560 errors. The full error will look like the extract below:

[ 2023-12-20 13:56:56.199 XXX ] Prepare for db operation
DBCA_PROGRESS : 10%
[ 2023-12-20 13:56:57.199 XXX ] Creating and starting Oracle instance
[ 2023-12-20 13:57:10.855 XXX ] Error in Process: C:\oracle\product\19.3.0.0\db_1\bin\oradim.exe
Enter password for Oracle service user: Instance created.
DIM-00019: create service error
O/S-Error: (OS 1053) The service did not respond to the start or control request in a timely fashion.
DBCA_PROGRESS : 12%
[ 2023-12-20 13:57:11.855 XXX ] [FATAL] ORA-12560: TNS:protocol adapter error
DBCA_PROGRESS : 20%
DBCA_PROGRESS : 100%
[ 2023-12-20 13:57:11.855 XXX ] [FATAL] ORA-12560: TNS:protocol adapter error
DBCA_PROGRESS : 10%
DBCA_PROGRESS : 0%

Cause

The most common cause of the issue comes down to a limitation of the ORADIM tool on Windows Server platforms. The tool will fail to create the oracle services with error DIM-00019 if the hostname of the server is longer than 15 characters.

 

Resolution

1. Change the hostname of the Oracle server to a name with less than 15 characters.

2. Reboot the Oracle server to apply the changes

3. Run DBCA tool again.