No data displayed in Analytics dashboard post portal upgrade
search cancel

No data displayed in Analytics dashboard post portal upgrade

book

Article ID: 277320

calendar_today

Updated On:

Products

CA API Developer Portal

Issue/Introduction

After Portal upgrade from version 5.0.2.6 to version 5.2.1, analytics data not getting captured in Analytics Dashboard.

Environment

API Developer Portal 5.2.x

Cause

Post-upgrade steps was ignored.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-developer-portal/5-2/install-configure-and-upgrade/install-portal-on-docker-swarm/upgrade-api-developer-portal/upgrade-to-api-portal-version-5-0.html

 

Resolution

After upgrading the API Portal to version 5.2.x, perform the following steps to ensure that Analytics reports (Traffic, Latency & Errors Report,
Quota Consumption Report, and Custom Report) are refreshed:

  1. Log in into the coordinator container shell as shown below:
docker exec -it <container id of the coordinator container> sh

     2. Reset the supervisors using the following curl commands:

curl -X POST  http://localhost:8081/druid/indexer/v1/supervisor/apim_metrics/reset
curl -X POST  http://localhost:8081/druid/indexer/v1/supervisor/apim_metrics_hour/reset