Unable to load Cloud-enabled Management Agent IIS Website Settings page
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Unable to load Cloud-enabled Management Agent IIS Website Settings page

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Article ID: 277229

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Updated On:

Products

IT Management Suite

Issue/Introduction

While going to the Cloud-enabled Management Agent IIS Website Settings page (SMP Console under Settings>Notification Server>Cloud-enabled Management>Setup), the page is not loading. Getting a generic error page:

The NS logs show messages like:

Entry 1:

HTTP Request failed: /Altiris/NS/Admin/Configuration/CertificateManagementPage.aspx

Object reference not set to an instance of an object.

Entry 2:

NegotiateCertificateRequest.Process() failed to get certificate chaing of agent web site.

Object reference not set to an instance of an object.

Also, the following CEM (Cloud-enabled Management) page failed:

  • Certificate Management

Environment

ITMS 8.7.x

Cause

Missing certificate for the 4726 port bindings under the Symantec Agent Site

Resolution

Add the proper CEM certificate for the Symantec Agent web site.

Try the following:

  1. Open IIS Manager and go to Sites>Symantec Agent
  2. Under Bindings (right-side frame), click on the CEM port (usually 4726)
  3. Make sure that there is a certificate assigned to it. Usually called <servername> CEM.

    Note:
    If there is not a certificate assigned to the CEM port, add one