Live Shell does not connect when the agent is behind a user-based proxy
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Live Shell does not connect when the agent is behind a user-based proxy

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Article ID: 277199

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Updated On:

Products

Endpoint Security Complete

Issue/Introduction

When you try to open a Live Shell connection to an agent that is behind a user-based proxy the connection fails. This occurs even if a proxy is defined in the Symantec Endpoint Security (SES) System policy.

Environment

SES Complete

Cause

The Live Shell connection is handed off to a Windows program running as SYSTEM, which does not have access to the user-based proxy configuration or the SES policies. 

Resolution

Workaround:

A. Use the Compliance (Host Integrity) policy to adjust the SYSTEM proxy settings in the registry before opening Live Shell. (This method requires knowledge of manipulating binary data in the Windows registry.)

or

B. Use your preferred method to execute the "netsh" command remotely and set the SYSTEM proxy settings on the endpoint.

Additional Information

Example netsh command:

netsh winhttp set proxy <SERVER>:<PORT>