Spectrum NCM config capture not working for Cisco running IOS 17.12
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Spectrum NCM config capture not working for Cisco running IOS 17.12

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Article ID: 277043

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Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum SSH window and NCM SSH is not working.

Spectrum is not able to connect i.e. Cisco IE9320 Stack  Catalyst L3 Switch Software (IE9K_IOSXE), Version 17.12.1, RELEASE SOFTWARE (fc5)

Other common ssh clients like putty are able to connect such devices on the same route.

The syslog message from such a device is:
Cisco IE9320 Stack
Cisco IOS Software [Dublin], Catalyst L3 Switch Software (IE9K_IOSXE), Version 17.12.1, RELEASE SOFTWARE (fc5)
Syslog Alarm vom Switch:
%SSH-3-NO_MATCH: No matching mac found: client hmac-sha2-256,hmac-sha2-512,[email protected],[email protected],hmac-sha1,hmac-md5,hmac-sha1-96,hmac-md5-96 server hmac-sha2[email protected],hmac-sha2[email protected].

Environment

Spectrum 23.3.x and older

Cause

sha2 hmac are not supported 

Resolution

As a workaround you can use hmac-sha256 or hmac-sha512 whcih needs to be configured on the device itself.
After this you will need to use JSCH libraries instead of the default Mindterm.
No other changes need to be done on the Spectrum scripts.

 

Link to using JSCH libraries

Additional Information

There is an enhancement request already opened (F146352) to add those HMACs, which is tentatively due in Q3, 2024 to be included in a future Spectrum release.