DSM Explorer takes time to be opened
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DSM Explorer takes time to be opened

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Article ID: 276990

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

On remote machine, DSM Explorer takes time to be opened (more than 1 minute).

In TRC_GUI*.log in Detail trace level we could see that there is a delay of 60 seconds in step "Retrieving Deployment portal data"

281123-13:58:52.4259031L|007732|00004464|GUI       |GUI_CM          |ITRMUtil.cpp        |000740|INFO   | Startup: Step 25 of 31 - Message: Retrieving Deployment portal data
281123-13:58:52.4264555L|007732|00004464|GUI       |GUI             |ITRMFeatureInterface|000201|DETAIL | ITRMFeatureInterface_Deployment::GetPortletInfo called
281123-13:58:52.4267246L|007732|00004464|GUI       |GUI             |ITRMFeatureInterface|000260|DETAIL | ITRMFeatureInterface_Deployment::GetPortletInfo bShowPortalTasks = true
281123-13:59:52.4652987L|007732|00004464|GUI       |GUI             |ITRMFeatureInterface|000352|DETAIL | ITRMFeatureInterface_Deployment::GetPortletInfo ends
281123-13:59:52.4653785L|007732|00004464|GUI       |GUI_CM          |ITRMUtil.cpp        |000367|DETAIL | Return from ITRMFeatureInterface(ITRMDeployment)->GetPortletInfo(). Operation took 60,0397s
281123-13:59:52.4653949L|007732|00004464|GUI       |GUI_CM          |ITRMUtil.cpp        |000350|DETAIL | ITRMFI_GetPortletInfo calling ITRMFeatureInterface(ITRMDIR)->GetPortletInfo()

 

On Domain Manager, in log TRC_CF_DMDEPLOY_*.log there are following error :

281123-13:58:54.0428789L|010536|000023fc|DMDeploy  |DmDeploy        |ccam.cpp            |000240|ERROR  | CAM unable to resolve the remote hostname.
281123-13:58:56.3055970L|010536|000023fc|DMDeploy  |DmDeploy        |cdmdeploy.cpp       |001664|ERROR  | Failed to return DSM_2_API_VERSION message to CAM queue CAI007732-00013 on host <HostName>

 

Environment

Client Automation - All Versions

Cause

Domain Manager has problems to resolved the hostname of Remote DSM Explorer to IP Address
 
Command
nslookup <host_name>
are not working

Resolution

Add or correct the hostname entry in the DNS server 

or

add the Remote DSM Explorer hostname in file c:\windows\system32\drivers\etc\hosts file on Domain Manager