Configuration saved successfully but could not publish configuration to the following host
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Configuration saved successfully but could not publish configuration to the following host

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Article ID: 276977

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You have updated a configuration on the Messaging Gateway and saved it. The result is a red error message that states:

configuration saved successfully but could not publish configuration to the following host - 

Followed by a list of scanners and guidance to check the Control Centre logs for more details.

Cause

This error can occur when the Control Centre cannot communicate with the Scanners listed in the error. This is often caused by either a problematic state of the Scanner's Agent service, an excessive number of policies or potentially due to a network issue between the Control Centre and the Scanner.

Resolution

For information on restarting the Scanner's Agent service related to this issue, please see the following article:

"Cannot find an Agent that is running" error in Messaging Gateway

If the error logs are followed with the following entry: java.net.SocketTimeoutException: Read timed out, Please see the following article:
Resolving Configuration Publishing Errors in Symantec Messaging Gateway

If the issue persists, it may be a network issue. Work with your network team to validate that the Control Centre can communicate with the listed Scanners on port 41002.