I accidentally installed a robot on the Primary Hub and now the hub is down
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I accidentally installed a robot on the Primary Hub and now the hub is down

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Article ID: 276947

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I can't connect to my primary hub via the Infrastructure Manager as the primary hub and robot seem to be down. 

I'm facing this issue since I accidentally installed a robot on the Primary Hub.

The controller.log and hub.log stopped logging information and they just show they went down. 

Environment

DX UIM any version

Cause

Accidentally installing a robot on top of a UIM Primary hub makes the Nimsoft Watcher Service registered under a different/new path that is not the primary hub executable. 

Resolution

1. Open the Windows Services, search for Nimsoft Watcher, and, in the properties, check what is the path of the nimbus.exe executable: 

2. The accidental robot install might have registered this Service to a new path. If the path is wrong, you will need to re-register the service to point to the correct original UIM install path.

3. For re-registering the service to point to the correct path an option is to edit the Windows Registry Manually:

•  Copy the correct path

•  Stop the Nimsoft Robot Watcher service

•  WIN+R > Regedit > HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services >NimbusWatcherService

•  Edit the ImagePath and set correct the path 

•  Start the Nimsoft Robot Watcher service

4. Delete the folders created by the accidental robot install. 

Additional Information

The Windows Registry can be also modified via command line: 

sc config <service name> binPath= <binary path>