PAM Processes Are Starting as Queued
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PAM Processes Are Starting as Queued

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Article ID: 276810

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

New ITPAM processes are starting as queued and are never completing

Restarting ITPAM resolves the issue temporarily, but the issue reoccurs and processes get stuck

Environment

ITPAM 4.3.5

Cause

Performance issue - The database is being overloaded with data from inflight flows and activeMQ messages

Resolution

Increase the noOfConsumers and Oasis.concurrent.calc.ops:

1. Log into PAM using an administrator account

2. Configuration > Expand Ochestrators > Click on the Orchestrator > Configuration Properties > Common Properties:

Set:

noOfConsumers to 150

Oasis.concurrent.calc.ops to 2000

3. Restart the Domain Orchestrator services

Additional Information