Live update shows success but result code shows 0x00011003 for Protection Engine 9.1
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Live update shows success but result code shows 0x00011003 for Protection Engine 9.1

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Article ID: 276784

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

Symantec Protection Engine (SPE) servers fail to apply new definitions even though lux.log shows success but the result code shows 0x00011003
Issue may occur randomly and restarting the SPE service resolves the issue.

lu.log will show error as below:

07:01:18.394023     [Component Result - START]
07:01:18.394023         Component ID: {CD657291-9FEB-46FD-8F22-4A67F2F0D3BE}
07:01:18.394023         Display Name: Stargate Definition
07:01:18.394023         PVL: Stargate-SPEforNAS 1.0 Definitions for x64-windows_MicroDefsB.CurDefs_SymAllLanguages
07:01:18.394023         Result Code: 0x00010000
07:01:18.394023         Result Message: OK
07:01:18.394023         [Package Result - START]
07:01:18.394023             File: 1680056386jtun_sgwino230327019.7z
07:01:18.394023             Result Code: 0x00011003
07:01:18.394023             Result Message: UNKNOWN
07:01:18.394023         [Package Result - END]
07:01:18.394023     [Component Result - END]
07:01:18.394023 [Session Results - END]
07:01:18.394023 [Session Summary - START]
07:01:18.394023     Components: 1
07:01:18.394023     Packages:   1
07:01:18.394023     Success:    1
07:01:18.394023     Fail:       0
07:01:18.394023 [Session Summary - END] 

Environment

SPE 9.1 on Windows OS

Cause

With SPE 9.0 onwards Virtual definitions concept was introduced and definition updates were delegated to controller process. 
Intermittently controller was deleting the virtual definitions while other threads were in process of creating them.

Resolution

The hotfix csapi.dll (attached to this KB) will now make sure that cleaning up of stale virtual home directory not happen while we are updating virtual definitions.

Platforms Supported: Windows

SPE_9.1.0_HF_01.zip – This is applicable to SPE version 9.1 only

Step to deploy hotfix:

  1. Stop Symantec Protection Engine service.
  2. Go to Symantec Protection Engine install location.
  3. Take back up of csapi.dll file.
  4. Copy csapi.dll (attached to this KB) at the same location under the Symantec Protection Engine installation directory.
  5. Ensure the permission and ownership of newly copied files are identical to backed-up file.
  6. Start the Symantec Protection Engine service.

Attachments

SPE_9.1.0_HF_01.zip get_app