SslConfig command returns InvocationTargetException error
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SslConfig command returns InvocationTargetException error

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Article ID: 276758

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Running the SslConfig command on a DX NetOps Performance Management Portal web server.

When choosing option 2 to "Configure SSL" the following error is seen. The command closes.

Unable to import certificates to complete SSL configuration with the SslConfig script.

Select your option: 2
Configure SSL
Are you sure you want to configure DX NetOps Portal to use https? This will stop all the DX NetOps Portal processes ([y/n]): y
Configuring DX NetOps Portal to use https
Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

Stack Trace:
java.lang.NoSuchMethodError: 'void org.apache.logging.slf4j.Log4jLoggerFactory.<init>(org.apache.logging.slf4j.Log4jMarkerFactory)'
        at org.apache.logging.slf4j.SLF4JServiceProvider.initialize(SLF4JServiceProvider.java:54)
        at org.slf4j.LoggerFactory.bind(LoggerFactory.java:183)
        at org.slf4j.LoggerFactory.performInitialization(LoggerFactory.java:170)
        at org.slf4j.LoggerFactory.getProvider(LoggerFactory.java:453)
        at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:439)
        at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:388)
        at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:414)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.<clinit>(AbstractLifeCycle.java:35)
        at com.ca.im.portal.sslConfig.impl.ssltest.ssltests.SSLCertificateTest.validateKeyStore(SSLCertificateTest.java:177)
        at com.ca.im.portal.sslConfig.impl.ssltest.ssltests.SSLCertificateTest.runTest(SSLCertificateTest.java:103)
        at com.ca.im.portal.sslConfig.impl.ssltest.SslTest.performTest(SslTest.java:62)
        at com.ca.im.portal.sslConfig.impl.app.SslConfiguration.checkForExistingCert(SslConfiguration.java:1142)
        at com.ca.im.portal.sslConfig.impl.app.SslConfiguration.configurePerformanceCenterForSSL(SslConfiguration.java:96)
        at com.ca.im.portal.sslConfig.impl.app.SslConfigUtility.configureSSL(SslConfigUtility.java:304)
        at com.ca.im.portal.sslConfig.impl.app.SslConfigUtility.showMainMenu(SslConfigUtility.java:195)
        at com.ca.im.portal.sslConfig.impl.app.SslConfigUtility.run(SslConfigUtility.java:64)
        at com.ca.im.portal.sslConfig.impl.SslConfig.main(SslConfig.java:64)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.base/java.lang.reflect.Method.invoke(Unknown Source)
        at com.zerog.lax.LAX.launch(Unknown Source)
        at com.zerog.lax.LAX.main(Unknown Source)
This Application has Unexpectedly Quit: Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

Environment

Dx NetOps Performance Management 23.3.4 and earlier 

Cause

3rd party tool updates

Resolution

This issue is resolved in DX NetOps 23.3.5 and later:

Symptom: After enabling HTTPS for NetOps Portal for the Single Sign-On website using the SSL Configuration tool (SslConfig), the NetOps Portal services do not fully run HTTPS because the keystore was not owned by the installation owner.
Resolution: With this fix, SslConfig now changes the owner of any new/modified files to the installation owner. In addition, SslConfig now can import the initial or updated signed certificate into the keystore.
(23.3.5, DE551477, 33283961)

Until able to upgrade, to work around the problem, run the following copy command on the Portal web server terminal CLI as the install owner.

cp /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/lib/log4j-slf4j2-impl-2.20.0.jar /opt/CA/PerformanceCenter/Tools/lib

The SslConfig command should no longer return the error. If it does open a new Support Case referencing this Knowledge Base article.