Is there maintenance for CA Roscoe for the next release of z/OS?
search cancel

Is there maintenance for CA Roscoe for the next release of z/OS?

book

Article ID: 27675

calendar_today

Updated On:

Products

Roscoe

Issue/Introduction

Is there maintenance for the next release of z/OS?  How do I find it and what do I have to do?

Environment

Release:
Component: ROSCOE

Cause

IBM z/OS, JES2; JES3

CA Roscoe

6.0

Resolution

You will always need to apply maintenance with every new release of z/OS and follow these instructions when you upgrade z/OS.

Finding the PTFs and Instructions

  1. Go to BROADCOM Support (z/OS Release Compatibility) 
  2. Login at the upper right
  3. Under Search By Product Name, enter Roscoe 
  4. This will bring up supported z/OS releases 
  5. Under your z/OS level, you will find the PTFs you require and instructions.

Steps to Accomplish the Upgrade

  • Specify the correct SYSTEM, MVSSPL and JESSPL parameters in the ROSGBL.
  • After upgrading MVS and/or JES, you must reassemble MRO6010, ROSGBL.
  • You need to modify the SMP/E procedure, CAIRO60 with updated syslibs to match z/OS system specifications.  
  • JES2 users must reinstall MRO6029, ROJES2XT to enable users to print the files from a job file.
  • JES3 local users must reinstall MRO6015, IATUX30 that's applicable to your system. It is required by the CA Roscoe job facility.

Note: JES3 Global users are not required to install IATUX30.

Additional Information

I would like to upgrade CA Roscoe ahead of the z/OS upgrade? Can I do it?

Refer to the CA Roscoe 6.0 MVS System Reference Guide for more information.