Installation fails in the Preconfiguration step
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Installation fails in the Preconfiguration step

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Article ID: 276500

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager ServiceDesk

Issue/Introduction

Installation of Service Desk failed in the Preconfiguration step.  Please advise.

Environment

Release 17.3

Cause

In the install.log file:

We see the step that failed in line 8322
<date> <time> INFO  [DeployThread] [DeployThread] task.sdm.preconfigure.steps.17.3 : failed

Scanning up in the log to find the problem, I see this at line 8302:
<date> <time> INFO  [DeployThread: EjecuciĆ³n de los pasos previos a la configuraciĆ³n para las actualizaciones de CA Service Desk Manager: 17.3] [PatchUtil] Renaming original NX.env failed.

We also found this error at line 9055:
<date> <time> ERROR [AWT-EventQueue-0] [Disable8dot3PrereqValidator] CASM150038dot3 Name is disabled at registry level. 8dot3 Name  should be enabled for installation

We checked this registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation

And found that the value had not been set to 0.

Resolution

For a successful installation, the value of registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation should be set to 0.  After making this correction, the installation succeeded.

Additional Information

More information about the requirement to enable the Windows 8dot3 name format can be found in the documentation here: CA Service Desk Manager Requirements - 8dot3 name creation