Cannot backup the database
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Cannot backup the database

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Article ID: 276387

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When trying to perform a backup SMG display the error message " Cannot backup the database". This error is usually followed by some additional diagnostic and error information.

Example

Cannot backup the database
Use of unitialized value $tmp_file in -e at /opt/Symantec/Brightmail/cli/sbin/db-backup line 909. ERROR: There is not enough disk space available to perform the backup. Space Required: 10744425 kb.

Cause

The most common cause of database backup failures is that there is insufficient free storage on the Messaging Gateway to complete the backup. In other situations the database itself may have become corrupted and need manual repair.

Resolution

Insufficient space for backup

Backups of the Messaging Gateway database require between 150% and 200% of the used storage space to perform a backup. This is because data needs to be first copied into a backup file and then compressed so as data storage increases the amount of free space needed to back up the system also increases.

If there is insufficient space on the Control Center to complete a backup

  1. Review the Free up disk space on Messaging Gateway appliances document for guidance on making more space available on the Control Center host
  2. Review the database storage limits set in Administration > Logs and Administration > Reports to ensure that data is not being retained for extended periods of time. If longer log retention is needed, please consider remote logging to a SIEM or other long term log storage device.
  3. Ensure that the log and report data is expunged on a daily basis to ensure that database cleanup activities occur on a regular basis

Database errors

If the Brightmail Log shows that database errors are preventing a backup of the Control Center database as shown below the database will need to be repaired before a database can complete. Messaging Gateway performs basic database maintenance each day but in some cases database corruption will need to be repaired manually. 

BrightmailLog.log
ERROR: Failed to run: '/opt/Symantec/Brightmail/mysql/bin/mysqldump': mysqldump: Got error: 144: "Table './brightmail/report_invalid_rcpt_summary' is marked as crashed and last (automatic?) repair failed" when using LOCK TABLES

Please see How to check and repair the database in Messaging Gateway for instructions on how to manually perform a repair and optimization of the Control Center database.