RC 65(65) on IXX00002 in job AL2DDRES
search cancel

RC 65(65) on IXX00002 in job AL2DDRES

book

Article ID: 276342

calendar_today

Updated On:

Products

Datacom Datacom/AD CA 7 Workload Automation

Issue/Introduction

When running CA 7 Workload Automation job AL2DDRES in our sandbox region, received these errors in STEP2:
DB02405I - PXX START MYRESJOB 73264 65(065) OPEN -2-    D-1 DBUTLTY INIT  
DB02406I - PXX END - DD STATEMENT MISSING                                
DB00501E - OPEN ERROR - RETURN CODE 65 (065) CXX=CXXNAME  IXX00002      
DB10045E - ABNORMAL TERMINATION DUE TO ERROR(S)                          
How do we fix this?

Cause

When you issued the CXXMAINT OPTION=DELETE command in STEP1, this deleted databases 2 and 15 from the CXX, meaning those file names were unavailable when STEP2 tried to run the INIT.

Resolution

To fix this error, you will need to add these DD statements to STEP2:

//IXX002   DD  DISP=SHR,DSN=datacomhlq.IXX002
//DD1002   DD  DISP=SHR,DSN=datacomhlq.DD1002
//IXX015   DD  DISP=SHR,DSN=datacomhlq.IXX015
//DDD015   DD  DISP=SHR,DSN=datacomhlq.DDD015
//MSG015   DD  DISP=SHR,DSN=datacomhlq.MSG015
//SIT015   DD  DISP=SHR,DSN=datacomhlq.SIT015

Hopefully, you'll be able to identify the proper DSNs for this MUF from your z/OS catalog through ISPF 3.4 so that you are using the right files.

In addition to the above DD statements, you will need to add INIT commands to get these file names back into the CXX. Please replace your input for STEP2 with this:

//SYSIN    DD  *                                            
  SET OPTION1=ECHO_FUNCTIONS                                
*                                                           
* Before executing this job, ensure the MUF is up.          
* Do NOT run this job without CA 7 and Datacom              
* Support personnel approval.                               
*                                                           
  ACCESS   DBID=002,STATUS=UTLTY,USERS=FAIL                 
  ACCESS   DBID=015,STATUS=UTLTY,USERS=FAIL                 
*                                                           
  COMM     DBID=002,OPTION=CLOSE                            
  COMM     DBID=015,OPTION=CLOSE                            
*                                                           
* LOAD THE DATADICTIONARY                                   
*                                                           
  INIT     DBID=002,AREA=IXX                                
  INIT     DBID=002,AREA=DD1                                
  LOAD     DBID=002,DDNAME=DD002BK,OPTIMIZE=YES,            
           FORMAT=BACKUP,SORT=10000000,SORTDFLT=YES,        
           SORTDD=SORTRPT,SORTWK=05,OPTION1='(I)'           
*                                                           
* LOAD THE DDD                                              
*                                                           
  INIT     DBID=015,AREA=IXX                                
  INIT     DBID=015,AREA=DDD                                
  INIT     DBID=015,AREA=MSG                                
  INIT     DBID=015,AREA=SIT                                
  LOAD     DBID=015,DDNAME=DD015BK,OPTIMIZE=YES,            
           FORMAT=BACKUP,SORT=10000000,SORTDFLT=YES,        
           SORTDD=SORTRPT,SORTWK=05,OPTION1='(I)'           
/*                                                          

Once you have added these to the JCL, you can add your good backup files to the DD002BK and DD015BK DD statements, and then restart the job at STEP2.

Additional Information

For future use, we recommend adding a CXX report to STEP1, so that your input looks like this:
//SYSIN DD  *
 ACCESS DBID=002,STATUS=OFF,USERS=FAIL
 ACCESS DBID=015,STATUS=OFF,USERS=FAIL
 COMM DBID=002,OPTION=CLOSE,DBID=002
 COMM DBID=015,OPTION=CLOSE,DBID=015
 REPORT DBID=002,AREA=CXX
REPORT DBID=015,AREA=CXX
 CXXMAINT DBID=002,OPTION=DELETE,DBID=002
 CXXMAINT DBID=015,OPTION=DELETE,DBID=015
 LOAD DBID=002,AREA=CXX,DDNAME=DBCXXBK,DBID=002 *LOAD STRUCTURE
 LOAD DBID=015,AREA=CXX,DDNAME=DBCXXBK,DBID=015 *LOAD STRUCTURE
/*

As always, please contact Broadcom support for Datacom if you have further questions.