Installing Endpoint Protection agent on Ubuntu minimal install
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Installing Endpoint Protection agent on Ubuntu minimal install

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Article ID: 276319

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Updated On:

Products

Endpoint Protection Endpoint Security Endpoint Security Complete

Issue/Introduction

Installation of Symantec Endpoint Protection (SEP) is not proceeding on Ubuntu minimal install with below error:

root@:/tmp# ./LinuxInstaller
sh: 1: file: not found
sh: 1: file: not found
sh: 1: file: not found
sh: 1: file: not found
LinuxInstaller: missing /tmp/inst7pqXpY/installagent.sh: No such file or directory

Same error is encountered while extracting the setup file:

root@:/tmp# ./LinuxInstaller -xt SEP
LinuxInstaller: extracting /tmp/SEP/compressed-and-gzipped-data-content.gz, size 4279301
sh: 1: file: not found
sh: 1: file: not found
LinuxInstaller: extracting /tmp/SEP/compressed-and-gzipped-data-content.gz, size 162726
sh: 1: file: not found
sh: 1: file: not found
files located at /tmp/SEP

Environment

Ubuntu 22.04.3 LTS Minimal Install

Cause

Missing dependent packages

Resolution

Ubuntu Minimal install is not a tested/certified OS for SEP.

A required prerequisite for SEP "dmidecode" is also not present on Ubuntu minimal install. It gets installed automatically in Ubuntu default installation.

  1. Following can be done as a workaround to install it:
    Install "dmidecode" package on Ubuntu.
    Example command:
    sudo apt-get update -y
    sudo apt-get install -y dmidecode
  2. Extract the SEP installer on another system (Ubuntu default install):
    ./LinuxInstaller -xt SEP
    Then copy the extracted directory to the system with minimal Ubuntu OS and install with the following command:
    ./installagent.sh

Note: Ubuntu may stop ‘Minimal’ Install Option from upcoming releases, so there are no current plans to support it in future release of SEP as well.

Note: If installation is about cloud SES linux client then after installation client will not be able to connect to ICDM console and will show similar outcome:

This is due to the software defect. Follow below workaround to solve this problem:

    • Get/copy to notepad the values x-epmp-customer-id, x-epmp-domain-id and connect_token from /etc/caf/CAFConfig.ini
      from one of the working linux systems that are connected to the same ICDM domain.
    • stop SEP services on affected: /usr/lib/symantec/stop.sh
    • backup the ini file cp /etc/caf/CAFConfig.ini /etc/caf/CAFConfig.ini.bak
    • edit the ini file with vim or any other text editor that is convenient to you ( Install vim as minimal version seems so not have it by default)
      vi /etc/caf/CAFConfig.ini
    • replace those 3 values x-epmp-customer-id, x-epmp-domain-id, connect_token with the ones you get from the working system and save ini file.
    • start the SEP service: /usr/lib/symantec/start.sh
    • check the status of the SEP client: /usr/lib/symantec/status.sh - should now show as connected.

Additional Information

Dependencies