PIM/PAMSC: サーバを再構築後、ポリシー/ルールセットの取得に失敗する
search cancel

PIM/PAMSC: サーバを再構築後、ポリシー/ルールセットの取得に失敗する

book

Article ID: 276310

calendar_today

Updated On:

Products

CA Privileged Access Manager - Server Control (PAMSC) CA Privileged Identity Management Endpoint (PIM)

Issue/Introduction

Privileged Access Manager Server Control ( 以下、PAMSC ) の拡張ポリシー管理を構成した環境で サーバを再構築後、エンドポイントに既存のポリシーの新しいバージョンが配布できなくなった。

エンドポイント側のログ、policyfetcher.log を確認すると以下のエラーが記録されていた。

failed to fetch signature for policy "NAME#14"
failed to fetch signature for ruleset "NAME#14"

しかしながら、DMS上のポリシーは正しくファイナライズされていることを確認済み

Environment

Privileged Identity Manager 12.8, 12.9, 14.0  ( エンタープライズ管理 )

Privileged Access Manager Server Control 14.0, 14.1  ( エンタープライズ管理 )

 

Cause

問題発生の原因は DMS と DH 間の同期が十分に行われていない可能性が推定されます。

DMS 上でポリシーが定義、更新されたファイナライズが完了していても、DH 上で不完全 (例えば、 ルールセットやポリシーが完全に定義されていてルールセットの内容等が空になってしまっているケースが想定されます。 ) となっている場合、DH 上で正しくファイナライズが完了しません。

GUI 上で設定したポリシーが DMS には正しく反映されますが、DH の配布に失敗したケースなどになります。
配布失敗の要因はシステム負荷やネットワーク状況による遅延等が考えられます。

Resolution

DMS/DH を再同期するために、以下のコマンドを実行してください。

dmsmgr -sync -self

最終的には同期に失敗した要因を確認する必要があります。
結果、いずれかのデータが破損している可能性も考えられます。

Additional Information

なお、本KBは以下の英文 KB を翻訳し補足しました。

Article ID: 265517: Failed to fetch signature for policy/ruleset received when trying to deploy a policy after a server rebuild