We are unable to view the DX NetOps Spectrum Licensed metrics under Usage Information in the Performance Center Console
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We are unable to view the DX NetOps Spectrum Licensed metrics under Usage Information in the Performance Center Console

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Article ID: 276264

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

In Portal, administration, usage information view, the values for the spectrum telemetry are not populating under usage information.

The values for PM are working as expected.

Environment

DX NetOps 22.2.x, 23.3.x

Cause

DE578881 - portal only waits 30 seconds for a reply from spectrum for the telemetry data.

If you enable ‘Restful Webservices debug’ in spectrum webpage, you will see the telemetry calls in the localhost_access_log-date in tomcat/logs:

- <USER> [19/Nov/2023:05:48:22 -0500] GET /spectrum/restful/telemetry/usageTelemetry HTTP/1.1 200 782 533601

533601 is ms to respond

..

You will also see the call fail in PCService.log on portal:

INFO  | Inventory Usage Data Service Scheduler-1 | 2023-11-20 04:39:29,093 | com.ca.im.portal.usagetelemetry.UsageTelemetryInventoryService  

      | Updating UsageTelemetry inventory metrics from all data sources at 11-20-2023 04:39:29

ERROR | Inventory Usage Data Service Scheduler-1 | 2023-11-20 04:39:59,171 | com.ca.im.portal.usagetelemetry.collector.UsageTelemetryRestCollector

      | Unable to get inventorydata from https://<oneclick-host>:8443/spectrum/restful/telemetry/usageTelemetry, restResponse StatusCode: 400

Response: null

Resolution

Broadcom is endeavoring to shorten the telemetry collection time from spectrum and to make the timeout configurable.

There is no eta at this time. (nov 2023)