Cannot open Symantec WSS Agent UI from system tray
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Cannot open Symantec WSS Agent UI from system tray

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Article ID: 276144

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

Users accessing internet via Cloud SWG using WSS Agent access method, after successfully authenticating with SAML.

WSS Agent installed with MCU=1 as most of the machines are shared devices.

WSS Agents pushed out to all devices using Microsoft SCCM (System Center Configuration Manager).

On a handful of machines, the WSS Agent UI appears to be frozen:  It is not possible to open the window by right-clicking "Open Symantec WSS Agent".

The WSS Agent and Cloud SWG service continue to work fine, despite this UI issue.

Restarting the host does not fix the issue.

Environment

Cloud SWG.

WSS Agent installed on Windows shared devices with MCU=1.

Microsoft SCCM used to deploy WSS Agent to all hosts.

Cause

SCCM policy changing a "user.config" file parameters that break the WSS UI. 

Resolution

Make sure that the SCCM policy is pushing the same settings to all WSS Agent machines consistently.

Additional Information

When troubleshooting, we were able to get a WSS Agent system state before and after the change.

Although nothing appeared to change around the time the UI broker in the Symantec WSS Agent directories, we did notice a change in a temp folder "user.config" file under

c:\Users\######\AppData\Local\Broadcom\wssa-ui.exe*\9.5.8698.23933\user.config (where 9.5.x was the WSS Agent version running).

where the file included:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <configSections>
        <sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=#######" >
            <section name="WSSNotifier.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=#####, Culture=neutral, PublicKeyToken=#######" allowExeDefinition="#######" requirePermission="false" />
        </sectionGroup>
    </configSections>
    <userSettings>
        <WSSNotifier.Properties.Settings>
            <setting name="authWinWidth" serializeAs="String">
                <value>965</value>
            </setting>
            <setting name="authWinHeight" serializeAs="String">
                <value>495</value>
            </setting>
        </WSSNotifier.Properties.Settings>
    </userSettings>
</configuration>

This is not a file that Symantec writes out as part of the WSS Agent install, and theoretically has no dependency on it!

We narrowed this down to configuration pushes via SCCM, and more importantly there was a difference in the parameters pushed to a working setup "user.config" file versus a non working setup. We then changed this user.config file "WSSNotifier" section values on the non working setup to match what we had in the working setup and the WSS Agent UI issues disappeared. Here are the working values from our setup.

        <WSSNotifier.Properties.Settings>
            <setting name="authWinWidth" serializeAs="String">
                <value>730</value>
            </setting>
            <setting name="authWinHeight" serializeAs="String">
                <value>625</value>
            </setting>
        </WSSNotifier.Properties.Settings>