A2A Client returns 408 error code for Secret
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A2A Client returns 408 error code for Secret

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Article ID: 276053

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

PAM Admin is attempting to use A2A with our Secrets Management.  They created a Vault, a Secret and Secret Authorizations in PAM, but they are getting the following error when attempting to use it:

C:\cspm\cloakware\cspmclient\bin>cspmclient.exe Test_Secret
wbAesDecryptFixedVarFIPS,Failed to decrypt, code: 0x806
408 null null, system error, signal: 11 caught, call Xceedium

Environment

PAM 4.1.3 - 4.1.5

Cause

The secret name had a space in the name

Resolution

Workaround for PAM 4.1.3 and 4.1.4 -> is to remove the space in the Secret Name.

In PAM 4.1.5, hotfix 4.1.5.02 resolves this issue, even though it doesn't specially state it in the resolved issues section.

Additional Information

In the cspm_client_logs.txt -> the secret in question was returning a 400 (success) return code with no errors.