Preferred JDBC/Provider configuration for data_engine connection to MSSQL in 20.4 CU9
search cancel

Preferred JDBC/Provider configuration for data_engine connection to MSSQL in 20.4 CU9

book

Article ID: 275907

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Which MS SQL connection provider is preferred for the UIM database connection, SQLOLEDB vs MSOLEDBSQL? Our DBAs use some enhanced features (MultiSubnetFailover for example, & others); They would like to know, which db connection is the most up-to-date, and what is that driver version that is packaged with data_engine 20.49. 

Environment

  • UIM 20.4 CU9
  • data_engine 20.49

Cause

  • Guidance

Resolution

As of  data_engine 20.41 or higher, in DX UIM 20.4 CU4 or higher,

Microsoft OLE DB Driver for SQL Server (MSOLEDBSQL) is supported, preferred, and recommended. It is also the most up-to-date.

MSOLEDBSQL version is 18.6.3.0 on UIM 20.4 CU7, OS: Windows 2016 Datacenter.

 - On MS Windows the driver version can be checked by navigating through Control Panel->Programs-> MSOLEDBSQL on the Primary hub

MSOLEDBSQL version is 18.6.6.0  on CU9 (Windows 2019 Standard).

Please also refer to:

Configure the MS SQL Driver