Tasks or Jobs fail with status 'Replicated'
search cancel

Tasks or Jobs fail with status 'Replicated'

book

Article ID: 275763

calendar_today

Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

When trying to run a Task on many systems and some of those machines will fail, and when those jobs fail the only status they get is "Replicated" as seen below:

Environment

ITMS 8.x

Cause

System is Unknown, or Agent Status is Not Tracked

Resolution

Run the following query to find machines with asset status other than "active":

SELECT *
FROM  vRM_Computer AS rmc
LEFT OUTER JOIN  ResourceAssociation AS resAssoc
   ON rmc.Guid = resAssoc.ParentResourceGuid
   AND resAssoc.ResourceAssociationTypeGuid = '3028166F-C0D6-41D8-9CB7-F64852E0FD01'

WHERE  (rmc.Deleted = 0)
  
AND (resAssoc.ChildResourceGuid <> '0A0203A5-D2B6-49f1-A53B-5EC31A89437C')    -- 'GUID for Active status

If the machine used for testing is in the results then run this query:

select * from vComputerResource where Guid = 'GUIDgoesHere'

If the test machine is not there then this means that the Task Server doesn't see it as an "active" machine that can be assigned tasks.

Additional Information

Similar situation w/ Deployment Solution: KB 224713