Attempts to reinstall Protection Engine keep failing due to Error 1923
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Attempts to reinstall Protection Engine keep failing due to Error 1923

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Article ID: 275734

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

Symantec Protection Engine (SPE) was uninstalled due to an issue with Sharepoint Servers.
During an attempt to re-install, following error is encountered:

Product: Symantec Protection Engine -- Error 1923.Service Symantec Protection Engine (symcscan) could not be installed. Verify that you have sufficient privileges to install system services.

The installation would go no further.

In another scenario, similar error as below is found for SPE controller service during re-install:

Cause

The registry entry for the symcscan service was never removed by the uninstall process and it was blocking the ensuing installation process's attempt to create the service and start it.

Resolution

  1. Open regedit.exe
  2. Go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services"
  3. Take a backup of registry and delete the following keys if present:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\symcscan
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\symccontroller
  4. Attempt the installation again.
    If there is still an issue, reboot the server then verify that the symcscan/symccontroller key is no longer present.