Jaspersoft 8.1.1 reports are not opening in the web browser
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Jaspersoft 8.1.1 reports are not opening in the web browser

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Article ID: 275600

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After upgrading to JasperSoft 8.1.1, users are seeing a different behavior when accessing reports.

In previous versions of JasperSoft (i.e. 7.9), end users were able to open the report directly in the web browser without downloading it first.

In the current version of JasperSoft 8.1.1, end users are not able to open the report directly in the web browser, rather it is being downloaded directly.

This issue is being seen with all web browsers (Edge, Chrome and FireFox).

Environment

JasperSoft 8.1.1

Cause

Product design change in JasperSoft 8.1.1

Resolution

Discussed this functionality change with Tibco Support.

The change to the current behavior of downloading the file instead of opening in the web browser was made intentionally because of several reported security vulnerabilities.

As a result, Tibco does not intend to change the behavior back to the previous state NOR will they provide any workaround to restore the previous functionality.