Alarm History Window in the Infrastructure Manager is not displaying any alarms
search cancel

Alarm History Window in the Infrastructure Manager is not displaying any alarms

book

Article ID: 275584

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Alarm History Window in the Infrastructure Manager is not displaying any alarms. I used this feature this morning and it was working fine. Right click in the Alarm window in the Infrastructure Manager and select Today (or any other option) and the Alarm History Window pops up and it is blank. 

Environment

  • Release: 20.4 CU8
  • nas 9.39-T2

Cause

  • possible nas corruption due to Windows Update

Resolution

  • IM alarm history stopped working (Today option displayed empty console window)
  • nas would not drop its port
  • Renamed transactionlog.db and database.db
  • nas transaction.log was 4 GB
  • Windows events->Application log showed a few nas.exe crashes and they seemed to occur when the alarm history window rendered empty
  • In the nas GUI, the nis_bridge was DISABLED which is NOT the default nas configuration.
  • Everything was working as expected earlier today/this morning but stopped working later on in the day
  1. Deactivated nas
  2. Reinstalled nas 9.39-T2 via rt-click Update version and overwrite.
  3. Activated nas
  4. Restored transactionlog.db and database.db
  5. Alarm history was completely restored.
  6. We also turned on the nis_bridge-> nis_bridge = yes