Getting error on CA SSO Agent:"Validation failed: Unable to initialize CA Single Sign-On Agent. Either failed to connect to the Policy Server or the Agent's hostname/secret/fipsmode is incorrect."
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Getting error on CA SSO Agent:"Validation failed: Unable to initialize CA Single Sign-On Agent. Either failed to connect to the Policy Server or the Agent's hostname/secret/fipsmode is incorrect."

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Article ID: 275513

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Updated On:

Products

CA API Gateway

Issue/Introduction

You are getting this error (PFA) in the CA SSO Agent. 

"Validation failed: Unable to initalize CA Single Sign-On Agent.  Either failed to connect to the Policy Server or the Agent's hostname/secret/fipsmode is incorrect."

CA API Gateway version 10.x

Environment

Release : 10.x

Cause

Getting error "Validation failed Unable to initialize CA Single Sign-On Agent. Either failed to connect to the policy server or the Agent's hostname/secret/fipsmode is incorrect" .

this triggered when a new CA SSO Configuration was added.

Due to the addition of the new configuration all other SSO Agents stopped working. 

In some case it can due to the DNS cannot resolve the SSO host name that will cause the connection fail. 

Resolution

- Resolve the hostname in the gateway, if it can not resolve, add it to DNS server or gateway hosts file. 

- For each of the SSO agents along with the newly created agent, create the new hosts and register it with the new hosts.